REBOL3 tracker
  0.9.12 beta
Ticket #0001971 User: anonymous


TypeWish Statussubmitted Date27-Feb-2013 01:20
Versionr3 master CategoryMezzanine Submitted byBrianH
PlatformAll Severitymajor Prioritynormal

Summary Rename MAXIMUM-OF and MINIMUM-OF to FIND-MAX and FIND-MIN, respectively
Description MAXIMUM-OF and MINIMUM-OF don't actually return the maximum or minimum of a series, they return the series at the position of the maximum or minimum. Gregg has suggested that these be renamed to FIND-MAX and FIND-MIN instead. This would allow us to create different MAXIMUM-OF and MINIMUM-OF functions which actually do return the maximum and minimum values (see #1972 for such a proposal).

Normally this would be against the (defacto) legacy naming rules, but we make an exception for functions that are rarely used and *really* badly named, especially when we have a much better use for the name. MAXIMUM-OF and MINIMUM-OF fit that description.

This issue was last mentioned in #1818, but was first brought up in AltME years ago. See also #428 for issues that relate to /skip behavior of these functions.
Example code


Assigned ton/a Fixed in- Last Update26-Feb-2014 16:21

27-Feb-2013 06:34

Ch.Ensel (aka ChristianE) suggested that these be named AT-MAXIMUM and AT-MINIMUM instead in #1818. However, the functions don't really seem related to AT. For AT, you already know and specify the position; for these functions, you are trying to find the position. These really seem like they're more related to FIND.
13-Mar-2013 01:33

I agree with this change. From the old AltMe chat on it, Ladislav was against it, but suggested doc string changes would help. Here were my proposals at that time:

FIND: "Returns the series where the value is found, or none if the value is not found."

FIND-MAX: "Returns the series where the largest value is found, or none if the series is empty."

AT-MAX: "Returns the series at the position where largest value is found, or none if the series is empty."

AT-MAX: "Returns the series at the largest value, or none if the series is empty."

I still prefer the FIND* variant over AT*, but either is better than what we have now.
20-Feb-2014 22:19

Requested #2110 to be better able to implement functions like these with the #428 record comparison rules.

Date User Field Action Change
26-Feb-2014 16:21 Ladislav Severity Modified minor => major
20-Feb-2014 22:19 BrianH Comment : 0004256 Added -
13-Mar-2013 01:59 Gregg Comment : 0003619 Modified -
13-Mar-2013 01:33 Gregg Comment : 0003619 Added -
27-Feb-2013 06:34 BrianH Comment : 0003528 Added -
27-Feb-2013 01:35 BrianH Description Modified -
27-Feb-2013 01:20 BrianH Ticket Added -